问答中心分类: Linux2个PHP版本不能调用同个redis库吗?
oneinst 提问 1年 前

服务器安装了php5.6和php7。
redis在php5.6的配置目录下面,php5.6也能正常调用redis。
然后我又安装了个php7。
我在php7的配置文件php.ini中去调用PHP5.6的文件:/usr/local/php/lib/php/extensions/no-debug-non-zts-20131226/redis.so
提示找不到动态库。
是不是还得给PHP7在安装一次redis?

1 问题
oneinstack 回答 1年 前

PHP7是不能调用php5.6 redis.SO的,重新源码编译适合php7 的redis.SO 再加载