请更新cmake

问答中心分类: Linux请更新cmake
SkyFaklist 提问 1月 前

编译mysql报错:CMake 3.5.1 or higher is required. You are running version 2.8.12.2
请升级cmake至最新版
当前可用最新版:https://github.com/Kitware/CMake/releases/download/v3.16.1/cmake-3.16.1-Linux-x86_64.tar.gz

4 问题
最佳答案
oneinstack 回答 1月 前
yum -y install cmake3
mv /usr/bin/cmake{,_bk}
ln -s /usr/bin/cmake3 /usr/local/cmake
oneinstack 回答 1月 前

centos6吗? 都已经用MySQL8版本了,建议使用centos7及以上系统!或者用二进制安装!

SkyFaklist 回答 1月 前

我使用的是Centos7.7
且已经升级Cmake,但还是出现了报错,具体信息在下方附件中
https://storge.sakurax.org/error_down/pt-1.png

SkyFaklist 回答 1月 前

根据您上面提出的shell指令执行之后再次执行Oneinstack的MySQL源码编译程序依然示报错,现在正在尝试自行编译MySQL,感谢您的协助