Let's Encrypt安装

问答中心分类: OneinStackLet's Encrypt安装
探路者 asked 6年 ago
./addons.sh安装Let's Encrypt:出现这种:
Could not find a version that satisfies the requirement acme==0.9.2 (from -r /tmp/tmp.GnkDQ1tKbo/letsencrypt-auto-requirements.txt (line 173)) (from versions: 0.0.0.dev20151006, 0.0.0.dev20151008, 0.0.0.dev20151017, 0.0.0.dev20151020, 0.0.0.dev20151021, 0.0.0.dev20151024, 0.0.0.dev20151030, 0.0.0.dev20151104, 0.0.0.dev20151107, 0.0.0.dev20151108, 0.0.0.dev20151114, 0.0.0.dev20151123, 0.0.0.dev20151201, 0.1.0, 0.1.1, 0.2.0, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.9.0, 0.9.1)
No matching distribution found for acme==0.9.2 (from -r /tmp/tmp.GnkDQ1tKbo/letsencrypt-auto-requirements.txt (line 173))
You are using pip version 8.0.3, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Let's Encrypt client installed successfully!
上述的提示是否正常?
谢谢!
 
 
 
 

3 Answers
探路者 answered 6年 ago
补充:安装完之后,建立SSL虚拟主机的时候并不出现使用Let's Encrypt建立SSL的选项了!是什么问题呢?

探路者 answered 6年 ago
补充:原来发现并没有安装成功:试了好几次都是这样!
2016-10-13 15:05:19 (307 KB/s) - ‘certbot-auto’ saved [44442/44442]
Bootstrapping dependencies for RedHat-based OSes...
yum is /bin/yum
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.aliyuncs.com
* epel: mirrors.aliyuncs.com
* extras: mirrors.aliyuncs.com
* updates: mirrors.aliyuncs.com
Package gcc-4.8.5-4.el7.x86_64 already installed and latest version
Package dialog-1.2-4.20130523.el7.x86_64 already installed and latest version
Package augeas-libs-1.4.0-2.el7.x86_64 already installed and latest version
Package 1penssl-1.0.1e-51.el7_2.7.x86_64 already installed and latest version
Package 1penssl-devel-1.0.1e-51.el7_2.7.x86_64 already installed and latest version
Package libffi-devel-3.0.13-16.el7.x86_64 already installed and latest version
Package redhat-rpm-config-9.1.0-68.el7.centos.noarch already installed and latest version
Package ca-certificates-2015.2.6-70.1.el7_2.noarch already installed and latest version
Package python-2.7.5-39.el7_2.x86_64 already installed and latest version
Package python-devel-2.7.5-39.el7_2.x86_64 already installed and latest version
Package python-virtualenv-1.10.1-2.el7.noarch already installed and latest version
Package python-tools-2.7.5-39.el7_2.x86_64 already installed and latest version
Package python-pip-7.1.0-1.el7.noarch already installed and latest version
Nothing to do
Creating virtual environment...
Installing Python packages...
Had a problem while installing Python packages.
Collecting argparse==1.4.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 6))
Downloading http://mirrors.aliyun.com/pypi/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Collecting pycparser==2.14 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 12))
Downloading http://mirrors.aliyun.com/pypi/packages/6d/31/666614af3db0acf377876d48688c5d334b6e493b96d21aa7d332169bee50/pycparser-2.14.tar.gz (223k
Collecting cffi==1.4.2 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 15))
Downloading http://mirrors.aliyun.com/pypi/packages/92/00/c8670a2898ab7121cdac3b59f4307977a86e08a59efd662f6c05200a2f11/cffi-1.4.2.tar.gz (365k
Collecting ConfigArgParse==0.10.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 32))
Downloading http://mirrors.aliyun.com/pypi/packages/d0/b8/8f7689980caa66fc02671f5837dc761e4c7a47c6ca31b3e38b304cbc3e73/ConfigArgParse-0.10.0.tar.gz
Collecting configobj==5.0.6 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 34))
Downloading http://mirrors.aliyun.com/pypi/packages/64/61/079eb60459c44929e684fa7d9e2fdca403f67d64dd9dbac27296be2e0fab/configobj-5.0.6.tar.gz
Collecting cryptography==1.3.4 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 36))
Downloading http://mirrors.aliyun.com/pypi/packages/f8/70/d7bd5c9c764732d5876ad34293e1ca55b2305a73ae6fcf1312202d1a798e/cryptography-1.3.4.tar.gz (384k
Collecting enum34==1.1.2 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 59))
Downloading http://mirrors.aliyun.com/pypi/packages/6f/e9/08fd439384b7e3d613e75a6c8236b8e64d90c47d23413493b38d4229a9a5/enum34-1.1.2.tar.gz (46k
Collecting funcsigs==0.4 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 62))
Downloading http://mirrors.aliyun.com/pypi/packages/5e/9f/025d4c92c6a1a94313cdf0813cd76f5700f8e5434fa15165090a6446ae22/funcsigs-0.4-py2.py3-none-any.whl
Collecting idna==2.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 65))
Downloading http://mirrors.aliyun.com/pypi/packages/7c/75/b566d769455929ee6ab308d8a1c6c5aecc4928e72b25d42dd019c99f7015/idna-2.0-py2.py3-none-any.whl (61k
Collecting ipaddress==1.0.16 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 68))
Downloading http://mirrors.aliyun.com/pypi/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
Collecting linecache2==1.0.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 71))
Downloading http://mirrors.aliyun.com/pypi/packages/c7/a3/c5da2a44c85bfbb6eebcfc1dde24933f8704441b98fdde6528f4831757a6/linecache2-1.0.0-py2.py3-none-any.whl
Collecting ndg-httpsclient==0.4.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 74))
Downloading http://mirrors.aliyun.com/pypi/packages/df/a8/e7d70a8dd58c206c57b754fe15e5eb5f302f63fb1bfde5f26a0f5b019557/ndg_httpsclient-0.4.0.tar.gz
Collecting ordereddict==1.1 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 76))
Downloading http://mirrors.aliyun.com/pypi/packages/53/25/ef88e8e45db141faa9598fbf7ad0062df8f50f881a36ed6a0073e1572126/ordereddict-1.1.tar.gz
Collecting parsedatetime==2.1 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 78))
Downloading http://mirrors.aliyun.com/pypi/packages/85/1f/13fc06097e516f6259d62cea502b116451321c96e18a9d0fff9da3442e02/parsedatetime-2.1-py2-none-any.whl
Collecting pbr==1.8.1 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 81))
Downloading http://mirrors.aliyun.com/pypi/packages/fc/37/94af8387babb09796d306b18cf94ee5c70388c875a16d8a88e471500452c/pbr-1.8.1-py2.py3-none-any.whl (89k
Collecting pyasn1==0.1.9 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 84))
Downloading http://mirrors.aliyun.com/pypi/packages/69/be/e8946f7867b84b0e61a613f6fd56f63266190b1a470f945178f7cbc4d0ae/pyasn1-0.1.9-py2.py3-none-any.whl
Collecting pyopenssl==16.0.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 96))
Downloading http://mirrors.aliyun.com/pypi/packages/b1/4e/54c8995d2de887919272c2b711cd430277ec33e0f7bb88cb564244c102b6/pyOpenSSL-16.0.0-py2.py3-none-any.whl (45k
Collecting pyparsing==2.1.8 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 99))
Downloading http://mirrors.aliyun.com/pypi/packages/85/b9/188515f35f78533b3f82966a2c3f1a71a86df8b801367ee75a77191a861d/pyparsing-2.1.8-py2.py3-none-any.whl (54k
Collecting pyRFC3339==1.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 108))
Downloading http://mirrors.aliyun.com/pypi/packages/9b/0a/decfa17e7707afca17d6e9595ff5c79c1c71c74063ad95576f897ed3a9f1/pyRFC3339-1.0-py2.py3-none-any.whl
Collecting python-augeas==0.5.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 111))
Downloading http://mirrors.aliyun.com/pypi/packages/41/e6/4b6740cb3e31b82252099994cea751c648b846aa7874343c31d68c2215be/python-augeas-0.5.0.tar.gz (90k
Collecting python2-pythondialog==3.3.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 113))
Downloading http://mirrors.aliyun.com/pypi/packages/25/c7/15337261381193a7add23a2aae61fb9e2e21f42b855072bbb70cab7198cc/python2-pythondialog-3.3.0.tar.bz2 (1.8M
Collecting pytz==2015.7 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 116))
Downloading http://mirrors.aliyun.com/pypi/packages/c0/28/973f0382c803b21734cd7e97e0590928148ee21b1cbe8f7fed8b506204fb/pytz-2015.7-py2.py3-none-any.whl (476k
Collecting requests==2.9.1 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 130))
Downloading http://mirrors.aliyun.com/pypi/packages/b8/f7/3bb4d18c234a8ce7044d5ee2e1082b7d72bf6c550afb8d51ae266dea56f1/requests-2.9.1-py2.py3-none-any.whl (501k
Collecting six==1.10.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 133))
Downloading http://mirrors.aliyun.com/pypi/packages/c8/0a/b6723e1bc4c516cb687841499455a8505b44607ab535be01091c0f24f079/six-1.10.0-py2.py3-none-any.whl
Collecting traceback2==1.4.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 136))
Downloading http://mirrors.aliyun.com/pypi/packages/17/0a/6ac05a3723017a967193456a2efa0aa9ac4b51456891af1e2353bb9de21e/traceback2-1.4.0-py2.py3-none-any.whl
Collecting unittest2==1.1.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 139))
Downloading http://mirrors.aliyun.com/pypi/packages/72/20/7f0f433060a962200b7272b8c12ba90ef5b903e218174301d0abfd523813/unittest2-1.1.0-py2.py3-none-any.whl (96k
Collecting zope.component==4.2.2 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 142))
Downloading http://mirrors.aliyun.com/pypi/packages/4c/c4/3f77127c876f49af478e8ea4dc223cda17730bb273c0d1606a4114c64008/zope.component-4.2.2.tar.gz (546k
Collecting zope.event==4.1.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 144))
Downloading http://mirrors.aliyun.com/pypi/packages/0e/87/75e3d62a3506953c2e56d15a150de31e5d92310e87db2c8b102dc01b0b8e/zope.event-4.1.0.tar.gz (476k
Collecting zope.interface==4.1.3 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 146))
Downloading http://mirrors.aliyun.com/pypi/packages/9d/81/2509ca3c6f59080123c1a8a97125eb48414022618cec0e64eb1313727bfe/zope.interface-4.1.3.tar.gz (141k
Collecting mock==1.0.1 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 164))
Downloading http://mirrors.aliyun.com/pypi/packages/15/45/30273ee91feb60dabb8fbb2da7868520525f02cf910279b3047182feed80/mock-1.0.1.zip (861k
Collecting letsencrypt==0.7.0 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 167))
Downloading http://mirrors.aliyun.com/pypi/packages/fd/21/0c6f33829fadec8aca0c1ebb4d6f8101c05899356a58d1b2e506cb77cf18/letsencrypt-0.7.0-py2-none-any.whl
Collecting acme==0.9.2 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 173))
Could not find a version that satisfies the requirement acme==0.9.2 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 173)) (from versions: 0.0.0.dev20151006, 0.0.0.dev20151008, 0.0.0.dev20151017, 0.0.0.dev20151020, 0.0.0.dev20151021, 0.0.0.dev20151024, 0.0.0.dev20151030, 0.0.0.dev20151104, 0.0.0.dev20151107, 0.0.0.dev20151108, 0.0.0.dev20151114, 0.0.0.dev20151123, 0.0.0.dev20151201, 0.1.0, 0.1.1, 0.2.0, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.5.0, 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.9.0, 0.9.1)
No matching distribution found for acme==0.9.2 (from -r /tmp/tmp.otTKYbeBk6/letsencrypt-auto-requirements.txt (line 173))
You are using pip version 8.0.3, however version 8.1.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Let's Encrypt client installed successfully!
What Are You Doing?
1. Install/Uninstall PHP opcode cache
2. Install/Uninstall ZendGuardLoader/ionCube PHP Extension
3. Install/Uninstall ImageMagick/GraphicsMagick PHP Extension
4. Install/Uninstall fileinfo PHP Extension
5. Install/Uninstall memcached/memcache
6. Install/Uninstall Redis
7. Install/Uninstall Let's Encrypt client
q. Exit
Please input the correct option:
 
 

oneinstack answered 6年 ago
手工安装let's 客户端试试