php 5.3.29 在ubuntu 16.04下安装失败

问答中心分类: PHPphp 5.3.29 在ubuntu 16.04下安装失败
hainuo 提问 2年 前

https://yunpan.cn/cPfJWJfLCwsei (提取码:ee38)
 
日志以上传,5.3.29安装失败  我不得不安装了7.0.5 别的没试 因为之前第一次安装地时候就是7.0.5 正常安装通过所以 在卸载后重新安装5.3.29失败后,我选择了7.0.5  
但是开发环境要求是5.3.29    有部分zend加密代码 没办法换版本 所以贴上来求助于作者。麻烦查看下是什么问题

问题标签:
13 问题
最佳答案
oneinstack 回答 2年 前

ubuntu16.04 openssl太新,而php5.3.29是几年前的,不兼容太新的openssl,不支持,需要自己安装openssl ,并编译php指定openssl路径。
说一句,操作系统用这么新,php这么老,鄙视