升级 PHP 时无法确认 libmcrypt 版本错误。

问答中心分类: PHP升级 PHP 时无法确认 libmcrypt 版本错误。
kmvan 提问 5月 前

log:

checking for mcrypt support… yes
checking for libmcrypt version… >= 2.5.6
checking for mcrypt_module_open in -lmcrypt… no
checking for mcrypt_module_open in -lmcrypt… no
configure: error: Sorry, I was not able to diagnose which libmcrypt version you have installed.
make: *** No targets specified and no makefile found. Stop.
Stoping php-fpm…
Gracefully shutting down php-fpm … done
make: *** No rule to make target ‘install’. Stop.
Starting php-fpm…
Starting php-fpm done
You have successfully upgrade from 7.1.4 to 7.1.6

系统:Debian GNU/Linux 9 (stretch) x64
内核:4.11.4
情况说明:从 7.1.4 升级到 7.1.6 (7.1.5)时候出现错误,虽然提示提供,只是脚本没有额外判断而已,实际是在检查依赖状态中停止了的。

问题标签:
2 问题
kmvan 回答 5月 前

突然发现,mcrypt 不是已经弃用的吗?

oneinstack 回答 5月 前

方便的话私信IP 密码