Lets Encpty SSL 无法使用,报错

问答中心分类: OneinStackLets Encpty SSL 无法使用,报错
Hxppdv asked 2周 ago

 
An unexpected error occurred:
ContextualVersionConflict: (idna 2.6 (/usr/local/python/lib/python2.7/site-packages), Requirement.parse(‘idna<2.6,>=2.5’), set([‘requests’]))
Please see the logfile ‘/tmp/tmpRmeyOc’ for more details.
Error: Let’s Encrypt SSL certificate installation failed!

2 Answers
Hxppdv answered 2周 ago

这是错误日志
2017-08-08 23:51:47,203:DEBUG:certbot.log:Exiting abnormally:
Traceback (most recent call last):
File “/usr/local/python/bin/certbot”, line 11, in <module>
sys.exit(main())
File “/usr/local/python/lib/python2.7/site-packages/certbot/main.py”, line 733, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File “/usr/local/python/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 203, in find_all
plugin_ep = PluginEntryPoint(entry_point)
File “/usr/local/python/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 50, in __init__
self.plugin_cls = entry_point.load()
File “build/bdist.linux-x86_64/egg/pkg_resources/__init__.py”, line 2290, in load
self.require(*args, **kwargs)
File “build/bdist.linux-x86_64/egg/pkg_resources/__init__.py”, line 2307, in require
items = working_set.resolve(reqs, env, installer)
File “build/bdist.linux-x86_64/egg/pkg_resources/__init__.py”, line 854, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
ContextualVersionConflict: (idna 2.6 (/usr/local/python/lib/python2.7/site-packages), Requirement.parse(‘idna<2.6,>=2.5’), set([‘requests’]))

oneinstack 管理员 answered 1周 ago
/usr/local/python/bin/pip install requests

执行上面命令试试