centos7.3 编译安装percona5.7 无法正常启动

问答中心分类: Databasecentos7.3 编译安装percona5.7 无法正常启动
davidtall asked 5年 ago
提示mysqld_safe ld_preload libraries can only be loaded from system directories (/usr/lib64, /usr/lib, /usr/local/mysql/lib)
百度解决办法
配置文件中添加:
[mysqld_safe]
malloc-lib=/usr/lib64/libjemalloc.so.1
 
加上以上配置后还是无效,提示同样的错误
 
卸载后使用二进制方式安装一切正常。
请问如果以后要升级percona,也是使用二进制的方式升级的吗?还是通过编译源码来升级的?

1 Answers
oneinstack answered 5年 ago
升级脚本是源码编译。