编译安装MySQL5.7.22出错了

问答中心分类: Database编译安装MySQL5.7.22出错了
zjxubinbin asked 3年 ago
出错描述

4 Answers

Best Answer

oneinstack answered 3年 ago

boost版本不对, mysql8.0 要求boost 1.66.0; mysql5.7 要求boost 1.59.0, 尝试将安装的boost版本删除再安装试试,如下

 rm -rf /usr/local/lib/libboost* /usr/local/include/boost

或者升级oneinstack 卸载mysql后重装

~/oneinstack/upgrade.sh oneinstack
~/oneinstack/uninstall.sh mysql
~/oneinstack/install.sh --db_option 1 --dbinstallmethod 2

zjxubinbin answered 3年 ago
OS: Ubuntu 17.10 64bit
语言: 简体中文 utf-8
oneinstack 版本:最新版

oneinstack answered 3年 ago
install.log 百度链接帖下!

zjxubinbin answered 3年 ago
我重新解压了一份Oneinstack,这次安装的是MySQL8.0 但是错误一样
https://pan.baidu.com/s/1JbZLmQhPbMMy004X7Q2AgA