ubuntu16.04上pureftpd启动失败

问答中心分类: Linuxubuntu16.04上pureftpd启动失败
idotce 提问 2周 前

发现失败后查看log发现pure-ftpd.pem创建失败
/bin/mkdir -p \’/usr/local/pureftpd/etc\’
/usr/bin/install -c -m 644 pure-ftpd.conf \’/usr/local/pureftpd/etc\’
make[2]: Nothing to be done for \’install-data-am\’.
make[2]: Leaving directory \’/home/ubuntu/Project/oneinstack/src/pure-ftpd-1.0.47\’
make[1]: Leaving directory \’/home/ubuntu/Project/oneinstack/src/pure-ftpd-1.0.47\’
~/Project/oneinstack/src ~/Project/oneinstack ~/Project/oneinstack
openssl: /usr/local/mysql/lib/libssl.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libssl.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libssl.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
WARNING: can\’t open config file: /export/home/pb2/build/sb_0-27973335-1522272694.3/openssl-1.0.2n-el6-x86-64bit/ssl/openssl.cnf
Unable to load config info from /export/home/pb2/build/sb_0-27973335-1522272694.3/openssl-1.0.2n-el6-x86-64bit/ssl/openssl.cnf
chmod: cannot access \’/usr/local/pureftpd/etc/pure-ftpd.pem\’: No such file or directory
Job for pureftpd.service failed because a configured resource limit was exceeded. See \”systemctl status pureftpd.service\” and \”journalctl -xe\” for details.
Pure-Ftp installed successfully!
然后发现openssl命令有些奇怪
openssl: /usr/local/mysql/lib/libssl.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libssl.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libssl.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
openssl: /usr/local/mysql/lib/libcrypto.so.1.0.0: no version information available (required by openssl)
WARNING: can\’t open config file: /export/home/pb2/build/sb_0-27973335-1522272694.3/openssl-1.0.2n-el6-x86-64bit/ssl/openssl.cnf
Unable to load config info from /export/home/pb2/build/sb_0-27973335-1522272694.3/openssl-1.0.2n-el6-x86-64bit/ssl/openssl.cnf

1 问题
oneinstack 回答 2周 前

看上去像openssl有过变更,openssl命令不能生成pure-ftpd.pem