localhost能打开 探针之类的文件都打不开了

问答中心分类: PHPlocalhost能打开 探针之类的文件都打不开了
LingLai 提问 3周 前

Linux新手  不好意思 求助下
我想看下php环境变量是否正确 就输入以下命令
php -v
Mon Jul 30 21:25:45 2018 (6861): Fatal Error Zend OPcache cannot allocate buffer for interned strings
我以为是环境变量得自己配置 然后我就Google下 修改了环境变量 之后连桌面都进不去了 又改回来了 export PATH=/usr/local/nginx/sbin:/usr/local/php/bin:$PATH 不知道是否和最初一样 改的对不对
之后查看php状态
service php-fpm status
● php-fpm.service – LSB: starts php-fpm
Loaded: loaded (/etc/init.d/php-fpm; generated)
Active: failed (Result: exit-code) since Mon 2018-07-30 20:56:23 CST; 5min ag
Docs: man:systemd-sysv-generator(8)
Process: 1108 ExecStart=/etc/init.d/php-fpm start (code=exited, status=1/FAILU
7月 30 20:56:23 keith-TM1701 systemd[1]: Starting LSB: starts php-fpm…
7月 30 20:56:23 keith-TM1701 php-fpm[1108]: Starting php-fpm Mon Jul 30 20:56:23
7月 30 20:56:23 keith-TM1701 php-fpm[1108]: failed
7月 30 20:56:23 keith-TM1701 systemd[1]: php-fpm.service: Control process exited
7月 30 20:56:23 keith-TM1701 systemd[1]: php-fpm.service: Failed with result ‘ex
7月 30 20:56:23 keith-TM1701 systemd[1]: Failed to start LSB: starts php-fpm.
我这个是不是php出问题了?实在不会弄 求助
 

问题标签:
2 问题
oneinstack 回答 3周 前

不能打开浏览器什么报错? 502 ? 还是?
尝试:
修改/usr/local/php/etc/php.d/02-opcache.ini
将opcache.enable=1修改为opcache.enable=0

LingLai 回答 3周 前

是502
十分感谢 按你的方法修改之后可以了 为啥开启这个opcache就运行不了了呢?
另外,我在wwwroot/default新建了ABC文件夹,为啥127.0.0.1/ABC不显示里边的PHP文件列表而是403呢?
再次感谢