已经按步骤走了,都是通的,但是还是连不上。

问答中心分类: Database已经按步骤走了,都是通的,但是还是连不上。
Everan 提问 3周 前

已经全部按上面的走完了。到了本地客户端链接就连不上,报错的提示是这样的:

Access denied. Authentication that can continue: publickey,password。
数据库版本8.0的,也查了一些资料,最后一步是修改
mysqld.cnf

将bind-address前加上#注释掉:

#bind-address= 127.0.0.1

最后重启就可以了,这一步找不到当前mysqld.cnf在哪里,就没试。看上面的流程是不需要这一步的,求大神帮帮忙!!!
1 问题
oneinstack 回答 3周 前

配置文件:/etc/my.cnf

1)MySQL8.0版本

# mysql -uroot -p
MySQL [(none)]> create user db_user@'%' identified by 'db_pass'; #创建用户
MySQL [(none)]> grant all privileges on db_name.* to db_user@'%' with grant option; #授权
MySQL [(none)]> exit; #退出数据库控制台,特别注意有分号

更多参考:https://oneinstack.com/question/oneinstack-how-to-configure-mysql-remote-connection/