求助!自带 shadowsocks.sh 安装失败!

问答中心分类: OneinStack求助!自带 shadowsocks.sh 安装失败!
John asked 6月 ago

背景:

安装oneinstack之后,之前安装的ss就无法使用了。
然后我就把装好的ss卸载了,挨个尝试、卸载了pip、go、plus都没用,
后来找到自带了一个安装文件,就试了一下
可是还是出错,后来发现这里就是推荐使用自带的ss安装程序。
特此求助!

错误信息:

Exception:
Traceback (most recent call last):
  File “/usr/local/lib/python2.7/dist-packages/pip/basecommand.py”, line 215, in main
    status = self.run(options, args)
  File “/usr/local/lib/python2.7/dist-packages/pip/commands/install.py”, line 335, in run
    wb.build(autobuilding=True)
  File “/usr/local/lib/python2.7/dist-packages/pip/wheel.py”, line 749, in build
    self.requirement_set.prepare_files(self.finder)
  File “/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py”, line 380, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File “/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py”, line 666, in _prepare_file
    check_dist_requires_python(dist)
  File “/usr/local/lib/python2.7/dist-packages/pip/utils/packaging.py”, line 48, in check_dist_requires_python
    feed_parser.feed(metadata)
  File “/usr/lib/python2.7/email/feedparser.py”, line 177, in feed
    self._input.push(data)
  File “/usr/lib/python2.7/email/feedparser.py”, line 99, in push
    parts = data.splitlines(True)
AttributeError: ‘NoneType’ object has no attribute ‘splitlines’
Shadowsocks-python install failed! Please visit https://oneinstack.com

系统信息:

1 GB Memory / 30 GB Disk / Ubuntu 16.04.1 x64

完整信息:

#######################################################################
#       OneinStack for CentOS/RadHat 6+ Debian 6+ and Ubuntu 12+      #
#                   Install Shadowsocks Server                        #
#       For more information please visit https://oneinstack.com      #
#######################################################################
Please input password for shadowsocks: 123qweasd   
Please input Shadowsocks port(Default: 9003): 
Hit:1 http://sgp1.mirrors.digitalocean.com/ubuntu xenial InRelease
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:3 http://sgp1.mirrors.digitalocean.com/ubuntu xenial-updates InRelease
Hit:4 http://sgp1.mirrors.digitalocean.com/ubuntu xenial-backports InRelease       
Fetched 102 kB in 1s (68.7 kB/s)                             
Reading package lists… Done
Reading package lists… Done
Building dependency tree       
Reading state information… Done
python-dev is already the newest version (2.7.11-1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
python-pip is already the newest version (8.1.1-2ubuntu0.4).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree        
Reading state information… Done
curl is already the newest version (7.47.0-1ubuntu2.2).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
wget is already the newest version (1.17.1-1ubuntu1.1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
unzip is already the newest version (6.0-20ubuntu1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
gcc is already the newest version (4:5.3.1-1ubuntu1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
swig is already the newest version (3.0.8-0ubuntu3).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
automake is already the newest version (1:1.15-4ubuntu1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
make is already the newest version (4.1-6).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
perl is already the newest version (5.22.1-9).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
cpio is already the newest version (2.11+dfsg-5ubuntu1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists… Done
Building dependency tree       
Reading state information… Done
git is already the newest version (1:2.7.4-0ubuntu1).
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-race-detector-runtime golang-1.6-src golang-race-detector-runtime golang-src
Use ‘apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[ez_setup.py] found
Requirement already satisfied: M2Crypto in /usr/lib/python2.7/dist-packages
Requirement already satisfied: greenlet in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: gevent in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: greenlet>=0.4.9 in /usr/local/lib/python2.7/dist-packages (from gevent)
Requirement already satisfied: shadowsocks in /usr/local/lib/python2.7/dist-packages/shadowsocks-2.9.0-py2.7.egg
Exception:
Traceback (most recent call last):
  File “/usr/local/lib/python2.7/dist-packages/pip/basecommand.py”, line 215, in main
    status = self.run(options, args)
  File “/usr/local/lib/python2.7/dist-packages/pip/commands/install.py”, line 335, in run
    wb.build(autobuilding=True)
  File “/usr/local/lib/python2.7/dist-packages/pip/wheel.py”, line 749, in build
    self.requirement_set.prepare_files(self.finder)
  File “/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py”, line 380, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File “/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py”, line 666, in _prepare_file
    check_dist_requires_python(dist)
  File “/usr/local/lib/python2.7/dist-packages/pip/utils/packaging.py”, line 48, in check_dist_requires_python
    feed_parser.feed(metadata)
  File “/usr/lib/python2.7/email/feedparser.py”, line 177, in feed
    self._input.push(data)
  File “/usr/lib/python2.7/email/feedparser.py”, line 99, in push
    parts = data.splitlines(True)
AttributeError: ‘NoneType’ object has no attribute ‘splitlines’
Shadowsocks-python install failed! Please visit https://oneinstack.com

2 Answers
oneinstack 管理员 answered 6月 ago

可否私信发我ip 用户名密码?

John answered 6月 ago

我已经重装系统,通过teddysun的libev一键安装脚本,和修改iptables搞好了。
不过印象中通过apt安装的pip好像版本号是8.x,然后pip提示更新,我就更新到9.0.1的版本了,
不知道和这个问题有没有关系