已解答
发布

升级nginx的时候,出现了下面的错误,请问怎么处理?
Please input upgrade Nginx Version(example: 1.9.15): 1.10.1
[openssl-1.0.2h.tar.gz] found
[pcre-8.38.tar.gz] found
Download [nginx-1.10.1.tar.gz] successfully!
[nginx-1.10.1.tar.gz] found
Press Ctrl+c to cancel or Press any key to continue…
make: *** No rule to make target `clean’.  Stop.
./configure: error: invalid option “–with-http_spdy_module”
make: *** No targets specified and no makefile found.  Stop.
Upgrade Nginx failed!

What Are You Doing?
        1. Upgrade Nginx/Tengine/OpenResty
        2. Upgrade MySQL/MariaDB/Percona
        3. Upgrade PHP
        4. Upgrade Redis
        5. Upgrade phpMyAdmin
        q. Exit

3 答案

发布

英语不灵光?不支持spdy了,把–with-http_spdy_module去掉或者是你写错了,1.10肯定是不支持了

#1
发布
管理员 2016-06-30

从1.8以下版本升级到1.9 会有这个问题,参数有变动

#2
发布

我是从1.9.x升级到1.10.1,但是中间试了1.9.15,也是一样的提示,我用的upgrade.sh,需要在哪里修改一下。

#3

请登录或者 注册 来提交答案