已解决
匿名用户 提问于 2015-11-25

You need set up your PHP with XSL extension

1 答案

发布
管理员 2015-11-25

停止php

# 如果没有安装apache:
service php-fpm stop
# 如果安装apache:
service httpd stop

开始编译

cd ~/oneinstack/src
tar zxvf php-5.6.15.tar.gz # 解压已经安装的php版本
cd php-5.6.15/ext/xsl
/usr/local/php/bin/phpize
./configure --with-php-config=/usr/local/php/bin/php-config
make && make install
cd /usr/local/php/lib/php/extensions
ls #看到no-debug-non-zts-20131226类似文件夹
cd no-debug-non-zts-20131226
ls #查看有没有 xsl.so
vi /usr/local/php/etc/php.ini
找到extension = "imagick.so" 下面添加一行
extension = "xsl.so

启动php

# 如果没有安装apache:
service php-fpm start
# 如果安装apache:
service httpd start
#1

请登录或者 注册 来提交答案